Wired and Wireless Network Outage | Nightingale Hall

Resolved

This issue has been fully resolved.
Posted Mar 24, 2026 - 17:54 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 10:29 EDT

Investigating

IT teams are investigating reports of intermittent wired and wireless outages across the first floor of Nightingale Hall. The team is en route to assess, updates will be shared to Statuspage as soon as they are available.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 24, 2026 - 09:52 EDT
This incident affected: Network Infrastructure (Network Power, NUnet (Wired Network / Physical), NUwave (Wireless Network / Access Points)).