This update was rolled-back to mitigate unexpected issues for managed devices. Community members don’t need to do anything and should no longer expect a prompt on their unmanaged devices. When the certificate update is rescheduled, IT Services will share details on IT Statuspage.
Posted Jun 29, 2025 - 20:54 EDT
Completed
The scheduled maintenance has been completed.
Posted Jun 29, 2025 - 07:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 29, 2025 - 06:00 EDT
Scheduled
The NUwave wireless network certificate will be updated during maintenance 6-7 a.m. ET on Sunday, June 29. The wireless.northeastern.edu network certificate renewal is an annual process with minimal impacts to community members across the global campus system.
Following this update, unmanaged, personal devices including laptops and phones will require the owner to manually accept the new certificate when prompted on their devices. Some devices may require reboot. Northeastern managed machines will automatically accept the new certificate.
For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.