The Banner Self Service upgrade has been completed. IT teams ensured that the cutover was successful and validated community member access and permissions.
For what to expect in version 9, read the Banner Self-Service highlights.
Posted Jan 23, 2026 - 14:46 EST
Completed
The scheduled maintenance has been completed.
Posted Jan 21, 2026 - 18:00 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 21, 2026 - 06:00 EST
Scheduled
Maintenance to upgrade Banner Self-Service to version 9 will take place from 3 a.m. - 3 p.m. PT / 6 a.m. - 6 p.m. ET on Wednesday, January 21.
Community members should expect to experience intermittent degraded performance when accessing Banner Self-Service during the maintenance window. To avoid impacts to work, avoid updating records or executing functions in Banner Self-Service during the maintenance.
After the upgrade, Banner Self-Service will feature a new look, improved navigation and layouts, and convenient paths to perform key tasks. Most Banner Self-Service links will change so continue accessing Banner and related services through the The Hubs.
Note: You may need to clear your browser cache after the upgrade if you have trouble navigating to Self-Service Banner.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jan 15, 2026 - 10:57 EST
This scheduled maintenance affected: Administration and Business (Banner - Self-Service, Banner - Student) and Enterprise Systems.