New Account Provisioning Unavailable l Workday Finance Launch

Scheduled for Jul 2, 18:30 EDT  -  Jul 4, 06:30 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 02, 2025 - 18:16 EDT

Scheduled

As part of the Workday Finance launch, the account provisioning process for new employees is temporarily unavailable. Service is expected to resume at the end of the business day, Thursday, June 3. Updates will be posted on Statuspage.

New employees who require access to Northeastern systems before then will need a sponsored account requested for them.

Learn how to request a sponsored account >

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 02, 2025 - 18:16 EDT
This scheduled maintenance affects: Account Access and Security (Faculty / Staff Accounts).