All Microsoft file storage services have been restored. OneDrive, SharePoint, and Teams file sharing are working normally.
Files saved locally during the outage have been automatically syncing to the cloud. Please verify your important files have uploaded successfully. The IT Service Desk remains available if you need assistance.
Thank you for your patience during this disruption.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 31, 2025 - 13:55 EDT
Update
Microsoft OneDrive and SharePoint services are back. You can now upload documents and save changes as you normally would.
File sharing in Microsoft Teams is returning more slowly. If you're still experiencing issues, completely quit and reopen Microsoft Teams. Full functionality may take additional time to restore.
Good news: Files saved locally during the outage are automatically syncing to OneDrive and SharePoint. Please verify your files have uploaded successfully before deleting local copies. The IT Service Desk is available to help.
IT teams will continue monitoring to ensure stable service. Thank you for your patience during this disruption.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 31, 2025 - 11:27 EDT
Update
Microsoft file storage services haven't returned after the 1-hour period. Microsoft is actively reviewing.
Microsoft has put a fix in and expects service to resume within the hour. IT teams are monitoring to confirm file storage returns as expected.
Posted Aug 31, 2025 - 09:37 EDT
Update
IT teams have been working through the night with Microsoft to restore service. While there's no estimated time for resolution yet, teams continue to actively pursue a fix.
Files remain in read-only mode, preventing uploads and saves. For urgent document needs, please continue to save documents locally to your computer.
Updates will be posted as soon as more information becomes available.
Posted Aug 31, 2025 - 07:13 EDT
Identified
The issue has been identified and IT teams have escalated to Microsoft to try to resolve this issue as quickly as possible.
Files are appearing as read-only, preventing document uploads and saves. This is also impacting file sharing in Microsoft Teams. For urgent document needs, save documents locally to your computer until the issue is resolved.
Posted Aug 30, 2025 - 22:36 EDT
Investigating
IT teams are investigating error messages in Microsoft services, including OneDrive and SharePoint, stating that files are in read-only. This is preventing new documents and uploads. Updates will be shared to the IT Statuspage as soon as they become available.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 30, 2025 - 22:02 EDT
This incident affected: Communication and Collaboration (Microsoft SharePoint, Microsoft Teams).