Degraded Service | PaperCut Print

Resolved

Papercut printing services are back to normal and IT teams have closed this incident.
Posted Apr 09, 2026 - 09:39 EDT

Identified

IT teams have identified a Papercut Printer service degradation.Print services are working slower than normal and printing will be delayed.

Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Apr 08, 2026 - 19:21 EDT
This incident affected: Computing and Software (PaperCut (General-use printing)).