Interruption to on-campus telephone service
Incident Report for Northeastern University - ITS
Resolved
This incident has been resolved.
Posted 4 months ago. May 31, 2019 - 08:52 EDT
Monitoring
All phone lines affected by this outage should be back to normal and receiving dial tones.
Posted 4 months ago. May 30, 2019 - 15:49 EDT
Identified
Some users are experiencing dial tone outage on their individual phone lines. There is a circuit board failure in Verizon's centrex complex affecting a number of individual lines at Northeastern. Verizon is on site and working to get a replacement board to restore service by the end of the day.
Posted 4 months ago. May 30, 2019 - 13:15 EDT
This incident affected: Other.