SMS and Phone Authentication Errors | Duo

Resolved

Duo has resolved this issue.
Posted Feb 14, 2025 - 09:14 EST

Identified

Community members are encountering errors when authenticating their accounts using Duo SMS and phone call delivery. Those impacted are advised to authenticate their accounts using the Duo app via push or mobile passcode, not SMS, until the issue is fully resolved.

Duo has reported that they've identified an issue on their end that's causing the errors and they're working to resolve it.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Feb 13, 2025 - 15:03 EST
This incident affected: Account Access and Security (Duo Security Phone Call Delivery, Duo Security SMS Message Delivery).