AV Systems Network Outage | Boston

Resolved

ITS teams have restored network access for AV systems. Community members have tested and confirmed that AV systems are reconnected to the wired network.
Posted Jun 02, 2025 - 13:58 EDT

Identified

ITS has identified that a DNS-related error is causing the AV systems connection issue. Updates will be shared as they become available.
Posted Jun 02, 2025 - 12:38 EDT

Update

ITS teams have confirmed that this issue is isolated to AV equipment. The wired and wireless network is working and accessible in classrooms and offices across Boston. Community members are advised to connect to AV equipment using an HDMI cable where available.
Posted Jun 02, 2025 - 12:14 EDT

Investigating

IT Services has received reports of wired network outages in Snell Library, Forsyth, Ell Hall, Ryder Hall, Kariotis, Curry Student Center, and Hayden Hall in Boston. This network outage is impacting classroom and conference room AV systems.

The wireless network isn't impacted at this time. Updates will be shared to IT Statuspage as ITS teams work to repair the network.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jun 02, 2025 - 12:02 EDT
This incident affected: Network Infrastructure (NUnet (Wired Network / Physical)) and Other.