Intermittent Wireless Connectivity

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 15:03 EST

Monitoring

IT teams made an update to stabilize connectivity on campus. Teams will continue to monitor.

If you experience any disruptions to service, please contact the IT Service Desk with your campus location. Reach out through 617.373.HELP [4357], help@northeastern.edu, or the Tech Service Portal.
Posted Jan 13, 2026 - 11:42 EST

Investigating

IT teams are investigating issues with intermittent wireless connectivity on the Boston campus. Updates will be shared to the IT Statuspage as they become available.

To report an issue, please contact the IT Service Desk with your campus location. Reach out through 617.373.HELP [4357], help@northeastern.edu, or the Tech Service Portal.
Posted Jan 12, 2026 - 16:15 EST
This incident affected: Network Infrastructure (NUwave (Wireless Network / Access Points)).