An issue from AWS temporarily impacted connectivity for some services, including Canvas. The issue has been resolved, and services are operating normally.
Teams will continue to monitor to ensure stability. No further impact is expected.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 16, 2026 - 08:50 EDT
Monitoring
IT teams are investigating reports of global AWS CloudFront service errors that may be affecting access to certain Northeastern services, including Canvas. As a result, some members of the Northeastern community may experience timeout errors or difficulty accessing Canvas.
IT Services is actively monitoring the situation and will provide updates as more information becomes available.
Instructure, the provider of Canvas, is posting updates on its status page: Instructure Status Page.
To report any issues, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 16, 2026 - 06:19 EDT
This incident affects: Teaching and Learning (Canvas) and Public Cloud Services (Amazon Web Services (AWS)).