Intermittent Wireless Connectivity | Global

Resolved

IT teams worked with the vendor to repair this issue.
Posted Jan 13, 2026 - 16:26 EST

Investigating

IT teams are investigating reports of intermittent wireless connectivity issues across the global campus system. Updates will be shared to the IT Statuspage as they become available.

To report an issue, please contact the IT Service Desk with your campus location. Reach out through 617.373.HELP [4357], help@northeastern.edu, or the Tech Service Portal.
Posted Jan 13, 2026 - 15:05 EST
This incident affected: Network Infrastructure (NUwave (Wireless Network / Access Points)).