Some Accounts Inaccessible

Resolved

This incident has been fully resolved.
Posted Apr 25, 2025 - 11:43 EDT

Update

Accounts have been fully restored, however there could still be delays with accessing various systems (ex. VPN, Concur). Access should resolve overnight, or sooner.

If issues persist over the weekend, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Apr 18, 2025 - 16:36 EDT

Update

IT Services has received reports of successful logins to previously locked accounts. Impacted faculty and staff should attempt to log in and access their accounts.

If still unable to log in, or to report additional issues, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Apr 18, 2025 - 12:30 EDT

Monitoring

Teams are applying the fix. Locked accounts are expected to start coming back over the next couple of hours as the fix fully processes in the system. As account access is restored, incoming email messages could be delayed.
Posted Apr 18, 2025 - 10:19 EDT

Update

Teams are continuing to work on fixing the locked accounts.
Posted Apr 18, 2025 - 09:02 EDT

Identified

Teams have narrowed the impact to be just faculty and staff, and have identified the likely cause. They're working on a fix. Will continue to share updates through Statuspage. ETA of next update is 9 a.m. ET.
Posted Apr 18, 2025 - 08:26 EDT

Update

Teams continue to actively engage on the issue and are working as quickly as possible to fix. Updates will continue to be shared via Statuspage. Next update will be posted by 8:30 a.m. ET, or sooner.
Posted Apr 18, 2025 - 08:02 EDT

Investigating

IT teams are investigating reports of some Northeastern accounts being inaccessible. Impacted accounts are unable to access Microsoft services, including email, Teams, and Office programs. The next update will be shared to the IT Statuspage by 8 a.m. ET.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Apr 18, 2025 - 07:28 EDT
This incident affected: Account Access and Security (Alumni Accounts, Faculty / Staff Accounts, Family / Other Accounts, Sponsored Accounts, Student Accounts).