Microsoft Service Impacts l Crowdstrike IT Outage Updates
Resolved
IT teams have verified that Northeastern systems and services are running as expected as it relates to last week's Microsoft outages. This issue is considered resolved.
Posted Jul 22, 2024 - 12:05 EDT
Monitoring
Due to the widespread Microsoft outages caused by the Crowdstrike IT update, Northeastern IT teams are monitoring Microsoft services. There's no evidence of any direct impacts to systems and services at Northeastern, but IT teams are aware and ready to take action as needed.

Microsoft has shared that the following services may be impacted:

- PowerBI: Services could go to read-only mode while issues are addressed.

- Microsoft Teams: Functions including presence, group chats, and user registration may not be available to use.

- Azure virtual machines: Some virtual machines running Windows client and server may require remediation.

To report an issue, or for any questions, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 19, 2024 - 09:39 EDT
This incident affected: Public Cloud Services (Azure) and Communication and Collaboration (Microsoft Teams).