Hardware Vending Services Offline | Oakland

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 07:17 EDT

Monitoring

The issue has been resolved and all hardware vending services have been restored.
Posted Mar 14, 2025 - 16:07 EDT

Identified

Hardware vending services are offline in Oakland. Community members on the Oakland campus are unable to reserve, retrieve, or return hardware at this time. ITS teams are working with the vendor to resolve the issue.

For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 14, 2025 - 15:30 EDT
This incident affected: Other.