Account Claims l Faculty, Staff, and Sponsored Accounts
Resolved
IT teams have successfully concluded tests monitoring this issue and it is now fully resolved.
Posted May 29, 2024 - 11:07 EDT
Monitoring
IT teams have deployed a fix and are seeing successful account claims. New faculty, staff, and sponsored employees can resume claiming accounts again.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 16, 2024 - 15:53 EDT
Investigating
IT teams are investigating reports regarding recently created or claimed faculty, staff, and sponsored accounts. Until further notice, new faculty, staff, and sponsored employees should avoid claiming their accounts.

Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 16, 2024 - 12:35 EDT
This incident affected: Account Access and Security (Faculty / Staff Accounts, Sponsored Accounts).