Services in International Village building has been restored in the past hour. Internet and printing can be used again for those in International Village office and residence building.
Work continues as planned to restore remaining services unavailable.
Posted Nov 01, 2025 - 10:22 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 01, 2025 - 06:01 EDT
Scheduled
Planning, Real Estate, and Facilities (PREF) is performing work on the 840 Columbus Ave campus construction project. This work will cause disruptions to internet and dependent services on Saturday, November 1 at several Boston campus buildings, including International Village, Renaissance Park, Renaissance Park garage, and 216 Mass. Ave.
At the International Village and Renaissance Park buildings, expect brief intermittent outages to internet connectivity during the 6 a.m. – 6 p.m. ET window.
At 216 Mass. Ave., a three-hour network outage is expected earlier in the day.
Understanding that the timing and length of this disruption may be challenging for some, the community’s flexibility and understanding is greatly appreciated.
Impacted Services: -Wi-fi and wired internet: Service, including NUwave, Eduroam, NURes-device and ResNet, will be unavailable in the affected buildings. - Door access: The GET Mobile ID and CBORD Mobile ID apps won’t work; only physical Husky Cards will allow access. Staff will be present in the INV residence hall to assist. - Printing services: Student and staff printing will be unavailable in the affected buildings.
University network services will continue to function normally across the rest of the Boston campus. All services in the affected buildings are expected to fully resume no later than 6 p.m. on Saturday, November 1.
Affected Buildings: -International Village Office Building -International Village Residence -Renaissance Park -Renaissance Park Garage -216 Massachusetts Avenue