Willis Hall Power Outage l Boston

Resolved

IT teams have restored all network services to Willis Hall.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 28, 2025 - 15:04 EDT

Monitoring

IT teams are responding to a power outage in Willis Hall. Network connectivity is being monitored during the response. Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Mar 28, 2025 - 13:50 EDT
This incident affected: Network Infrastructure (Network Power).