Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 28, 2025 - 17:00 EDT
Scheduled
Maintenance to upgrade WebSphere services will occur today, Wednesday, May 28 beginning at 2 p.m. PT, 5 p.m. ET, and 10 p.m GT. Community members will experience an outage to the service applications listed below.
Impacted services: Banner Finance Banner Web Services uAchieve LDAP Services Salesforce Forms Software Distribution
All impacted services are expected to be fully restored by close of the maintenance window.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted May 28, 2025 - 09:32 EDT
This scheduled maintenance affected: Account Access and Security (Directory Services), Administration and Business (Banner - Finance, Banner - Self-Service, Salesforce), and Enterprise Systems, Other.