Premium License Errors l Claude

Monitoring

Anthropic has corrected the renewal error that blocked the Claude Premium plan from use. All Northeastern Claude services have now been restored. Please log out and back in if the error is still appearing.
Posted Jun 30, 2026 - 08:27 EDT

Update

IT Services is in touch with Anthropic and will share updates as they’re available on Anthropic’s fix.
Posted Jun 30, 2026 - 08:14 EDT

Identified

Northeastern has renewed its agreement with Anthropic, the provider of Claude AI, including Claude Premium licenses. However, due to an error by Anthropic, Premium licenses are temporarily unavailable. IT Services is awaiting Anthropic to restore service.
Posted Jun 30, 2026 - 08:13 EDT
This incident affects: Artificial Intelligence (Claude by Anthropic).