IT teams have implemented a fix and delayed emails are now starting process from ServiceNow. Community members don't need to resend emails, submit tickets on the Service Hub, or directly call for support.
Teams will continue monitoring to ensure stability.
Posted Jun 19, 2026 - 14:31 EDT
Investigating
IT teams are investigating reports of issues with sending and receiving emails on ServiceNow. Community members may be unable to send or receive emails and notifications through ServiceNow.
In the meantime, urgent messages should be sent via tickets through the Service Hub or direct calls. This includes urgent messages to: -Registrar -IT Services -Housing -SFS -OGC -GEO -Undergraduate Research -University -Health Plan -Career Design -Pure Tutoring -Off-campus Engagement -The Center for Student Involvement -Husky Court Services -Honors -Community -Engaged Teaching and Research -Veteran Services -Housing -We Care
Updates will be provided as more information becomes available.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jun 19, 2026 - 14:14 EDT
This incident affects: Administration and Business (ServiceNow).