Service Outage l Husky Card Access

Resolved

This incident is resolved. Husky card services are fully restored.
Posted Jun 04, 2026 - 09:32 EDT

Identified

IT teams have identified the issue and are implementing a fix.

Updates will be provided as more information becomes available.
Posted Jun 04, 2026 - 09:05 EDT

Investigating

IT teams are investigating reports of issues with Husky Card access.

Community members may experience problems accessing buildings using their Husky Cards. This issue appears to be impacting multiple individuals, including contractors, third-party vendors, and conference housing guests.

Work is underway to identify the root cause and restore normal access as quickly as possible. Updates will be shared as more information becomes available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jun 04, 2026 - 09:00 EDT
This incident affected: Student Services (Husky Card (CBORD / Husky Card Activity)).