Microsoft service degradation

Resolved

Microsoft has resolved this issue and services should be working as expected.
Posted Jan 23, 2026 - 17:29 EST

Monitoring

Microsoft is experiencing degraded services where some functionality or apps may be unavailable. There are also reports of "451 4.3.2 temporary server issue" error messages when attempting to send or receive email through Outlook.

Other affected services include Exchange Online, Microsoft 365 suite, Microsoft Defender XDR, Microsoft OneDrive, Microsoft Purview, SharePoint Online.

Microsoft is sharing updates at https://status.cloud.microsoft/ and Northeastern IT teams are monitoring.
Posted Jan 22, 2026 - 17:15 EST
This incident affected: Communication and Collaboration (Exchange (Email), Microsoft Excel, Microsoft SharePoint, Microsoft Teams, Microsoft Word).