Power and Network Outage | Stearns Center
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 10:09 EDT
Identified
Due to flooding on the 4th floor, the power was turned off in the Stearns Center in Boston. Network access is unavailable at this time.

The expectation is that the building will be back up and running for start of business on Tuesday, April 2, 2024. Updates to this issue will be shared here as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Apr 01, 2024 - 19:40 EDT
This incident affected: Network Infrastructure (Network Power).