Log In Issues | Family Hub

Resolved

This incident has been resolved.
Posted 29 days ago. Feb 13, 2025 - 12:25 EST

Monitoring

IT teams have identified and fixed the issue. Community members have reported that they can now log in and access the Family Hub.
Posted 30 days ago. Feb 12, 2025 - 10:05 EST

Investigating

IT teams are investigating reports from community members who are encountering log in errors when connecting to the Family Hub.

To report an issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.
Posted 30 days ago. Feb 12, 2025 - 09:58 EST
This incident affected: Account Access and Security (Family Hub).