Zoom Licensing l Global

Resolved

Zoom has fixed the incorrect licensing. Faculty and authorized staff are now licensed as expected.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 10, 2026 - 15:31 EDT

Investigating

The vendor, Zoom, has incorrectly reassigned faculty and authorized staff to a Basic Zoom license. As a result, affected users may encounter the 40-minute limit for hosted meetings associated with Basic Zoom licenses.

Zoom is aware of the issue and is investigating. Updates will be provided as more information becomes available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 10, 2026 - 15:19 EDT
This incident affected: Teaching and Learning (Zoom Web Client).