"I Am Here," Student Hub blocks and activities, Banner, NUWorks, and other impacted services are back and working as expected again. IT teams applied a fix as quickly as possible to restore service.
For any additional questions or issues, the IT Service Desk is available 24/7 to assist.
Posted Aug 26, 2025 - 23:57 EDT
Identified
IT teams have found a likely cause and are working on a fix that should restore service to the impacted apps in approximately 30 minutes (by about 11:45 p.m. ET).
Updates will continue to be shared on Statuspage.
Posted Aug 26, 2025 - 23:15 EDT
Update
IT teams are continuing to work the issue as quickly as possible to restore service, including "I Am Here" and other Student Hub blocks and actions.
Posted Aug 26, 2025 - 23:10 EDT
Investigating
IT teams are investigating Shibboleth single sign on (SSO) not functioning. As a result, access to "I Am Here", Banner course registration, Family Hub, NUWorks, and other services using Shibboleth for sign on is impacted. Updates will be shared to the IT Statuspage as they become available.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 26, 2025 - 22:31 EDT
This incident affected: Account Access and Security (Single Sign On (SSO)).