Microsoft Teams and Outlook | Degraded Service
Resolved
This issue has been resolved by the vendor.
Posted Jun 08, 2023 - 11:13 EDT
Update
The vendor and ITS teams continue to monitor the solution to ensure this issue is fully resolved.

For any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Jun 06, 2023 - 16:02 EDT
Monitoring
A solution has been implemented. The vendor and ITS teams continue to monitor.

For any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Jun 05, 2023 - 17:03 EDT
Identified
The vendor has identified the issue and is working on repairs.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Jun 05, 2023 - 13:18 EDT
Investigating
Microsoft is investigating reports of Outlook and Teams not loading for some community members. Outlook web, desktop clients, and mobile apps are impacted. ITS teams are engaged with the vendor. Vendor updates may be found at portal.office.com/servicestatus.

To report this issue, or for any questions, please contact the IT Service Desk at 617.373.HELP [4357] or through the Tech Service Portal at service.northeastern.edu/tech.
Posted Jun 05, 2023 - 11:30 EDT
This incident affected: Communication and Collaboration (Exchange (Email), Microsoft Teams) and Other.