Services are continuing to operate. This issue is resolved.
Posted Aug 17, 2026 - 12:29 EDT
Monitoring
A fix has been implemented and impacted services have returned for all community members. Teams will continue to monitor.
Posted Aug 17, 2026 - 09:29 EDT
Identified
IT teams have identified the issue and are implementing a fix to resolve.
Posted Aug 17, 2026 - 09:21 EDT
Update
IT teams have identified the issue and are implementing a fix to resolve.
Posted Aug 17, 2026 - 09:21 EDT
Investigating
IT teams are investigating reports that multiple university systems are inaccessible from non-Northeastern networks. Affected services may include Banner, Tableau, Husky Card Center, and RMS Mercury.
Work is underway to identify the issue and restore access. Updates will be provided as more information becomes available.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 17, 2026 - 09:11 EDT
This incident affected: Administration and Business (Banner - Advancement, Banner - Finance, Banner - Human Resources, Banner - Self-Service, Banner - Student).