Student self-service applications
Incident Report for Northeastern University - ITS
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 21, 2019 - 20:52 EDT
Monitoring
The issue causing the student self-service applications to be unavailable has been addressed. Students and parents should be able to access their accounts.
Posted about 2 months ago. Aug 21, 2019 - 13:42 EDT
Investigating
There are confirmed reports that students and parents are unable to access the self-service system to claim accounts or submit parent accounts. This issue is being investigated.
Posted about 2 months ago. Aug 21, 2019 - 10:59 EDT
This incident affected: Enterprise Systems.