Banner is currently unavailable.
Resolved
This issue has been resolved. Students are successfully accessing Banner and registering for classes.
Posted Apr 11, 2024 - 11:27 EDT
Monitoring
IT teams are reporting that services are back up and are monitoring traffic. Students can try accessing course registration and other Banner services again through the Student Hub.

If issues persist, please report them to the IT Service Desk at 617.373.4357.
Posted Apr 11, 2024 - 10:19 EDT
Update
Troubleshooting continues to identify a fix for the issue. Banner authenticated services remain unavailable.
Posted Apr 11, 2024 - 09:43 EDT
Investigating
IT teams continue to troubleshoot. Students are still unable to access authenticated Banner services, including registration for courses.
Posted Apr 11, 2024 - 09:02 EDT
Monitoring
IT teams have restarted services and there are reports of students being able to access Banner again.
Posted Apr 11, 2024 - 08:54 EDT
Investigating
Banner is experiencing issues at this moment impacting courses registration. Technology team is currently engaged in troubleshooting. We appreciate your patience.
Posted Apr 11, 2024 - 08:37 EDT
This incident affected: Administration and Business (Banner - Self-Service, Banner - Student, Course Registration and Management).