The new NUwave certificate was successfully implemented. Some community members may need to re-enter their login credentials to re-connect to NUwave on managed or unmanaged devices. If you encounter issues connecting to NUwave, try connecting to NUnet wired network or to eduroam wireless network.
Posted Jul 02, 2025 - 09:09 EDT
Completed
The scheduled maintenance has been completed.
Posted Jul 02, 2025 - 02:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2025 - 21:00 EDT
Scheduled
The NUwave wireless network certificate will be updated during maintenance from 9 p.m. ET on Tuesday, July 1 until 2 a.m. ET on Wednesday, July 2. The wireless.northeastern.edu network certificate renewal is an annual process with minimal impacts to community members across the global campus system.
Unmanaged, personal devices including laptops and phones will require the owner to manually accept the new certificate when prompted on their devices. Some devices may require reboot. Northeastern managed machines will automatically accept the new certificate.
For any questions, or to report an issue, please contact the IT Service Desk at 617.373.HELP [4357] or +44.20.3318.2507, help@northeastern.edu, or by visiting the Tech Service Portal.