Access Errors l Enterprise Systems

Update

Monitoring continues and teams are continuing to take proactive steps when necessary to ensure services remain stable and to address underlying causes.
Posted Sep 02, 2025 - 08:52 EDT

Monitoring

IT teams have restored service. ITS will continue to actively monitor to ensure services remain working as expected.
Posted Aug 20, 2025 - 16:35 EDT

Identified

IT teams are addressing reports of these issues today and working to restore access to services as quickly as possible.
Posted Aug 20, 2025 - 15:44 EDT

Monitoring

All services are currently up and community members are successfully logging in to university systems. IT teams are actively monitoring to ensure services remain working as expected.
Posted Aug 16, 2025 - 13:36 EDT

Investigating

IT teams are investigating reports of intermittent internal server errors and other issues accessing university systems, including Banner, NUworks, Navigate, and others. Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Aug 16, 2025 - 13:08 EDT
This incident affects: Administration and Business (Banner - Advancement, Banner - Finance, Banner - Human Resources, Banner - Self-Service, Banner - Student) and Enterprise Systems.