Degraded Service | GET Mobile App (CBORD)

Update

The vendor reports ongoing intermittent outages to CBORD. University community members may continue to experience issues with the GET Mobile App until this issue is resolved by CBORD. Updates will be shared to IT Statuspage as available.
Posted Jan 22, 2026 - 11:22 EST

Investigating

IT teams are investigating a vendor issue affecting Husky Card services. The vendor, CBORD, has reported a service outage that may cause degraded service or an outage to the Husky Card application for some university community members. Updates will be shared to IT Statuspage as available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jan 21, 2026 - 16:18 EST
This incident affects: Student Services (Husky Card (CBORD / Husky Card Activity)).