National Service Outage | Verizon Wireless

Resolved

Verizon Wireless mobile services are operational, and mobile service has been restored.
Posted Jan 15, 2026 - 11:11 EST

Investigating

Verizon Wireless mobile service customers are currently experiencing a national service outage, prompting mobile phones to show an ‘SOS’ message.

IT Services teams are investigating the issue. Updates will be shared on Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jan 14, 2026 - 14:12 EST