Wireless Outage l Boston Campus

Resolved

All network connectivity services have remained stable on the Boston campus. Wireless and wired connections are working normally.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Sep 10, 2025 - 16:51 EDT

Monitoring

IT teams have implemented a fix and confirmed that network access has been restored across the Boston campus.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Sep 09, 2025 - 17:14 EDT

Update

IT teams continue to actively troubleshoot network connectivity issues affecting the Boston campus. Next update by 5:30 p.m. ET.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Sep 09, 2025 - 16:59 EDT

Update

IT teams are actively troubleshooting network connectivity issues affecting the Boston campus. All wireless networks remain unavailable. Wired ethernet connections are experiencing degraded service and may be intermittently unavailable while troubleshooting continues.

Next update by 5 p.m. ET.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Sep 09, 2025 - 16:39 EDT

Investigating

IT teams are investigating reports of wireless connectivity issues affecting the Boston campus. Community members are unable to connect to the wireless network or experiencing intermittent disconnections. Wired ethernet connections seem unaffected.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Sep 09, 2025 - 16:06 EDT
This incident affected: Network Infrastructure (NUnet (Wired Network / Physical), NUwave (Wireless Network / Access Points)).