Zoom Interruptions l Global Network

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 18:45 EDT

Monitoring

Zoom reported that they've restored service and university community members have confirmed they can access their Zoom accounts. IT teams will continue to monitor.
Posted Apr 16, 2025 - 17:07 EDT

Investigating

Zoom is investigating issues that's affecting multiple services. Members of the Northeastern community can use Microsoft Teams as an alternative tool for meetings and classes. Northeastern ITS will provide updates on Statuspage as they become available.

For any questions or assistance, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Apr 16, 2025 - 15:54 EDT
This incident affected: Teaching and Learning (Zoom Web Client).