MyNortheastern login screen isn't loading
Incident Report for Northeastern University - ITS
Resolved
The MyNortheastern portal and login are back to normal.
Posted 2 months ago. Aug 15, 2019 - 20:51 EDT
Monitoring
MyNortheastern portal users can now resume accessing the site in the way they typical do. The login screen for visitors to my.northeastern.edu is now loading. Teams will be continuing to monitor. Thanks for your patience.
Posted 2 months ago. Aug 15, 2019 - 15:35 EDT
Identified
The login screen is not loading for users who visit my.northeastern.edu and click the login button. Teams are working to address this issue.

Meanwhile, impacted users can still sign in to the portal through the following direct links.

Students: https://my.northeastern.edu/group/student
Employees: https://my.northeastern.edu/group/employee
Parents: https://my.northeastern.edu/group/parent
Posted 2 months ago. Aug 15, 2019 - 13:47 EDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Aug 15, 2019 - 13:22 EDT
This incident affected: myNortheastern & Services.