NUwave-Guest Network Outage | Boston
Resolved
ITS teams have restored NUwave-guest network access for the Boston campus.
Posted Nov 20, 2024 - 15:07 EST
Investigating
IT Services is investigating reports of a NUwave-guest outage in Boston. Please attempt to connect to the network using Eduroam if you experience this issue. Updates will be shared on Statuspage as available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Nov 20, 2024 - 10:09 EST
This incident affected: Network Infrastructure (NUwave (Wireless Network / Access Points)).