Missing data l Family Hub

Monitoring

IT teams have made a change that is expected to fix the problem. Teams are monitoring and validating that information is now showing in the Family Hub.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Sep 09, 2026 - 16:11 EDT

Identified

IT teams have identified an issue affecting the Family Hub, where some site visitors may see blank or null values for student information. Teams are actively working on a fix and monitoring the situation. The IT Statuspage will provide updates as more information becomes available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Sep 09, 2026 - 13:00 EDT
This incident affects: Account Access and Security (Family Hub).