Xfinity Unavailable | Boston
Resolved
This issue has been resolved.
Posted Jul 15, 2024 - 09:22 EDT
Monitoring
IT teams continue to monitor this issue to ensure it is fully resolved.
Posted Jul 12, 2024 - 17:00 EDT
Identified
IT teams identified the cause of this issue and implemented a solution. Tests are ongoing to ensure this issue is resolved.
Posted Jul 12, 2024 - 12:40 EDT
Investigating
Community members are unable to login to access Xfinity services in residence halls on the Boston campus. Upon login, an error is displayed. IT teams are investigating.

To report an issue, or for any questions, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 12, 2024 - 11:59 EDT
This incident affected: Other.