IT Services identified the issue and confirmed ServiceNow is working as expected. Additionally, Knowledge Base articles are appearing as intended. This issue will continue to be monitored.
Posted Oct 30, 2024 - 19:10 EDT
Investigating
IT Services has received additional reports of permalinks to Knowledge Base articles leading to a broken link and is now investigating those reports.
Posted Oct 30, 2024 - 14:53 EDT
Identified
ITS teams have identified the cause of this issue and are working to update the ServiceNow platform to improve load times.
Posted Oct 30, 2024 - 13:39 EDT
Update
IT Teams continue to investigate the continued performance issues. Updates will be shared to Statuspage as they become available.
For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Oct 30, 2024 - 12:29 EDT
Investigating
IT teams are investigating issues with the ServiceNow platform and slow load times. This is impacting service portals and agent views. Ticket and case creations is impacted and slower than usual. Inbound emails to help@northeastern.edu and other service areas are also slow.
Updates will be shared to Statuspage within the hour, or sooner if available.
Posted Oct 30, 2024 - 11:19 EDT
This incident affected: Enterprise Systems and Administration and Business (ServiceNow, ServiceNow Mobile App).