Xfinity on Campus is Inaccessible
Incident Report for Northeastern University - ITS
Resolved
Students can now log in to Xfinity on Campus as they normally would. The university worked with Comcast to resolve the issue that was preventing students from being able to access.

The IT Service Desk is available for any further questions or assistance. Please contact them at 617.373.HELP [4357], help@northeastern.edu, or through the Tech Service Portal at services.northeastern.edu/tech.
Posted Oct 26, 2020 - 14:15 EDT
Investigating
Students are unable to log in to Xfinity on Campus for on-demand, streaming video. The university is working with Comcast to resolve the issue and access.
Posted Oct 26, 2020 - 10:44 EDT
This incident affected: Other.