Service Disruption | Student Hub

Monitoring

The root cause has been discovered to be related to the existing network disruption. Services have been restored as part of the network remediation efforts.
Posted Jun 30, 2026 - 21:44 EDT

Investigating

IT teams are investigating an issue impacting Student Hub. Student may be unable to access the service and may encounter an error message stating that access is restricted.

Updates will be provided as more information becomes available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jun 30, 2026 - 21:10 EDT
This incident affects: Student Services (Student Hub).