Slowness to Faculty Grade Submissions l Banner

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 10:47 EST

Update

This issue has been fully resolved.
Posted Jan 05, 2026 - 09:28 EST

Update

IT teams are in communication with the vendor, and are continuing to investigate this issue.
Posted Dec 17, 2025 - 11:30 EST

Investigating

IT teams are aware of an issue affecting faculty grade submissions in Banner, and understand this is happening during a critical time for grade submissions. The issue has been identified and escalated to the vendor, Ellucian.

Faculty uploading large grade spreadsheets are experiencing timeouts that prevent successful submission.

Recommended workaround: Break larger class rosters into multiple spreadsheets of 50 students or fewer before uploading. For detailed grade submission instructions, visit the Faculty Grade Submission guide.

The university is working with Ellucian to resolve this issue as quickly as possible. Updates will be posted as available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Dec 15, 2025 - 18:01 EST
This incident affected: Administration and Business (Banner - Self-Service).