PaperCut Print Balance Error

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 16:29 EDT

Monitoring

IT teams have resolved the PaperCut issue. Student printing balances should now reflect the actual value from before the issue started.
Posted Sep 15, 2025 - 11:50 EDT

Investigating

IT teams are investigating reports that students are getting "Insufficient funds" errors when trying to release jobs to PaperCut printers even though they have sufficient print credit. A temporary balance of $25 has been applied to all student printing accounts to avoid interruptions to student printing capabilities. Updates will be shared to IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Sep 15, 2025 - 09:22 EDT
This incident affected: Computing and Software (PaperCut (General-use printing)).