Shibboleth Single Sign On (SSO) is down

Monitoring

IT Teams have remediated the issue and are monitoring service to ensure stability.
Posted Jul 09, 2026 - 19:48 EDT

Investigating

IT teams are investigating Shibboleth single sign-on (SSO) not functioning. As a result, access to Banner, Student Hub, and other services using Shibboleth for sign-on is impacted. Updates will be shared to the IT Statuspage as they become available.

For any questions, or to report an issue, please contact the IT Service Desk 24/7 at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Jul 09, 2026 - 19:33 EDT
This incident affects: Account Access and Security (Single Sign On (SSO)).