Intermittent errors and fluctuating usage limits l Claude.ai

Investigating

IT Services is aware of intermittent errors and fluctuating usage limits impacting Northeastern's Claude.ai service. These issues are related to current platform limitations, and IT teams are actively monitoring and working with Anthropic to address issues. Knowing this is disruptive to some, the community's patience is greatly appreciated.

Updates will be shared as available.
Posted Mar 13, 2026 - 11:46 EDT
This incident affects: Artificial Intelligence (Claude by Anthropic).