Banner Self-Service and Banner Admin Pages are back online. Some data may see refresh delays and may be out-of-date.
Teams are continuing to verify that all functionality has come back up as expected. Community members should report any errors they come across to the IT Service Desk at help@northeastern.edu.
Posted Mar 25, 2026 - 16:25 EDT
Update
IT teams continue to conduct maintenance. Teams expect to finish the maintenance, perform tests, and bring the Banner Self-Service and Banner Admin Pages services back online today. Statuspage will share the next update by 4 p.m. ET today.
Posted Mar 25, 2026 - 09:47 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 24, 2026 - 10:33 EDT
Scheduled
IT teams are conducting unplanned, critical maintenance on Banner Self-Service. The system will be temporarily unavailable or experience degraded performance during this maintenance, including course registration add/drop, viewing grades, viewing course schedules, viewing unofficial transcripts, and other Registrar functions.
Students are still able to view course schedules and information in the Student Hub and in Canvas.
This maintenance is expected to take 48 hours to complete. Updates will be posted to Statuspage as available.
Posted Mar 24, 2026 - 10:32 EDT
This scheduled maintenance affects: Administration and Business (Banner - Self-Service, Banner - Student, Course Registration and Management).