Degraded Network Service | Carter in Boston

Identified

IT teams have identified damage to the network fiber serving Carter, which is causing network degradation for the facility. IT teams are engaged with the vendor to schedule repairs. The maintenance scheduled will be shared as soon as it's available.
Posted Nov 07, 2025 - 09:42 EST

Investigating

IT teams are investigating reports of a degraded network service at the Carter Playground on Columbus Ave in Boston. Updates will be shared as they become available.

For any questions or support, please contact the IT Service Desk at 617.373.HELP [4357], help@northeastern.edu, or by visiting the Tech Service Portal.
Posted Nov 06, 2025 - 12:04 EST
This incident affects: Network Infrastructure (NUnet (Wired Network / Physical)).